I finally got around to jailbreaking my iphone4 running iOS 5.1.1.  I used Absinthe 2.0.2 for windows.  It went well enough till it locked up on me.  I ran it again and this time got this error. Could not connect to lockdown There is a similar error called lockdown error -5.  Both errors are really… Read More

We have been waiting, and as promised, iOS 5.1.1 untethered jailbreak is out called  Absinthe 2.0.  Its already up to 2.0.2, so check the site before updating. {update: be sure to use Absinth 2.0.2 Absinthe v2.0.2 (Win) Absinthe v2.0.2 (Mac) Absinthe v2.0.2 (Linux) } Today’s release supports all iPads, iPhones, and iPod touches except for… Read More